My Epson NX620 wireless printer won't connect to my new Hitron router

jwfox
Grasshopper

I just changed my Shaw wifi plan. As part of that change Shaw installed a new Hitron wireless router. It connects fine to several devices in my house, but not my Epson NX620 wireless printer, which previously worked fine with my old D-Link wireless router.

 

The printer can see the Hitron router, and the password works fine. The printer's status report page says it passes the Wireless Network Name (SSID) check, the communication mode check, security mode check, MAC address filtering check, and security key/password check. But the IP address check fails, saying "Incorrect IP address is assigned to the printer." Which I don't understand, because the printer says its IP address is 192.168.0.16, which the is the same as the IP address that's listed for the printer in the router's list of wireless clients, and is different than the IP address assigned to to any other wireless device in our house.

 

I have tried adding the printer's MAC address to the router's list of managed wireless clients, setting the block rule to "allow all"; it made no difference.

The router's wireless client list says the printer's IP address is self-assigned instead of DHCP-IP, even though DHCP-IP is enabled. Is that the problem, and if so, how  do I fix it?

Labels (1)
1 Reply

Re: My Epson NX620 wireless printer won't connect to my new Hitron router

Moderator
Moderator

Hey jwfox,

Thank you for reaching out! Based on what you are saying, you may need to complete a factory reset on your printer. I'd recommend giving that a try so the Hitron router can assign it a different IP address. Does the printer have an ethernet input available for you to test if it works on the Hitron network (just to rule everything out)? Let me know how it goes!

Cheers,

Tony | Community Mod.

0 Kudos
Reply
Loading...
TALK TO US
Need more help?