Wireless Epson printer won't print with new Shaw Hitron router


I just changed my Shaw wifi plan. As part of that change Shaw installed a new Hitron wireless router. It connects fine to several devices in my house, but not my Epson NX620 wireless printer, which previously worked fine with my old D-Link wireless router.

The printer can see the Hitron router, and the password works fine. The printer's status report page says it passes the Wireless Network Name (SSID) check, the communication mode check, security mode check, MAC address filtering check, and security key/password check. But the IP address check fails, saying "Incorrect IP address is assigned to the printer." Which I don't understand, because the printer says its IP address is, which the is the same as the IP address that's listed for the printer in the router's list of wireless clients, and is different than the IP address assigned to to any other wireless device in our house.

I have tried adding the printer's MAC address to the router's list of managed wireless clients, setting the block rule to "allow all"; it made no difference.

Given that the printer was working fine with the old router, I'm confident that the origin of the problem has to do with the new router. Hope someone can tell me how to fix it. This printer isn't that old, there's no reason why I should have to go buy a new printer to fix this problem.

Labels (1)
1 Reply

Re: Wireless Epson printer won't print with new Shaw Hitron router


Hey jwfox,

I see you have a similar discussion here. I will continue our conversation there.


Tony | Community Mod.

0 Kudos
Need more help?