Learn how to troubleshoot error XRE-07004 on Ignite (formerly BlueCurve) TV. This article provides insight into some basic troubleshooting tips to fix error code XRE-07004 on Ignite TV. Find additional TV troubleshooting tips for Ignite TV for these common error codes.

Error message

On-screen message

"Sorry, we're having some trouble. This program is not available to watch at the moment. Please try again in a few minutes. XRE-07004."

 

Cause

This error may occur if there’s an issue with the On Demand service.

Troubleshooting tips

To troubleshoot this error:

  1. Verify that the coaxial cable connections are secure on your TV Player (XG1v3 or XG1v4) and Portal(s) (XiD).
  2. Power cycle the main TV Player.
    • Disconnect the power cable and then reconnect it after 10 seconds.
  3. Power cycle the Portals on any other TV that is displaying this error.
    • Disconnect the power cable and then reconnect it after 10 seconds.
  4. Try renting/playing the On Demand title again.
  5. If the error still occurs, speak with a support representative.
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