Port forwarding broken

Not applicable

Port forwarding works if the START and END port are the same but broken if they are different. The premise of START (EXTERNAL) port and END (INTERNAL) port is if i get a request on 443 for ssl and have it set up on something on my internal network on a diff port (hass.io) 8123 than port forwarding with a start port of 443 and end port of 8123 would do this; but the router web UI errors out when trying to set this rule!!!!! Shaw please fix this web UI bug, this is important for some people!

Labels (1)
Tags (1)
3 Replies

Re: Port forwarding broken

anothermike
Grasshopper

I had same issue. I ended up using port forwarding and port triggering. IE, forward port 483, and then trigger port 483 to port 8938. 

0 Kudos
Reply
Loading...

Re: Port forwarding broken

Not applicable

I need 443 specifically for let's encrypt certs for my home automation stuff. The router has predefined ports in a drop down menu for port forwarding and 443 is one of them. The web Gui works as long as you don't try and forward any of shaw's predefined ports. 

0 Kudos
Reply
Loading...

Re: Port forwarding broken

Shaw Squad

Hi tsp84, port forwarding normally doesn't work like this.  The start and end ports are for ranges.  Port forwarding only sends traffic for a specific port to that same port on another machine in your network.  If you were to forward 443, all traffic coming to your house would go to your home assistance instance, and if you did a range of 443 to 8123, all traffic on those ports would go to your hass instance.  I think that you're looking more for a reverse proxy.  I've had similar difficulties with needing to change how forwards were working for some of my hass.io add-ons (and running multiple home assistance instances in my house).  I found that the Nginx Proxy Manager add-on in the community add-on store ended up doing exactly what I (and you) was hoping for (and is more secure than doing a blanket port forward on 443).

0 Kudos
Reply
Loading...
TALK TO US
Need more help?