Why is my internet speed so slow?

andrewe
Grasshopper

I have Shaw 150 internet and receive 170 Mbps speeds when I hook my laptop directly up to the fibre modem. I have to have the modem reprovisioned to install my router (Ubiquiti USG). Once the router is installed my speeds drop to 20-30 Mbps on any device on the network. Even just having the same laptop directly wired to the router nets me a max of 21 Mbps. I have tried 2 other completely different routers with the same result. I have also replaced cables and had the USG's tech support team show me that the router is functioning correctly and is fully capable of much higher speeds.

I am lost and very frustrated especially since the internet speeds used to be as advertised and slowed down without me making any changes. Shaw says that since I am capable (with only one computer hooked directly to the modem) of obtaining the advertised speeds that this is not a problem that they can help me with.

I value and appreciate all input.

Labels (1)
1 Reply

Re: Why is my internet speed so slow?

Moderator
Moderator

Hey andrewe,

Thank you for reaching out! That is certainly very odd. Generally, for most fiber-fed buildings there is a 3rd party router that is included from us. Do you have any of the 3rd party routers listed here? If so, when you connect that to the fiber modem directly, are you getting 150 Mbps + with a direct ethernet connection to a PC? Keep me posted.

Cheers,

Tony | Community Mod.

0 Kudos
Reply
Loading...
TALK TO US
Need more help?