Bluecurve pods not connecting / fixed!


I received bluecurve in the mail Tuesday the 21, it took me until May 24th, 3 days of screwing around with it any chance i had to get it working.

I am officially 2 modems, 6 pods, 3 phones, multiple outlets of different locations, 10+ hours and 5 agents into figuring out the problem.

Usually with computer stuff its just process of elimination, the pods didnt connect... I used my MOTO 6G phone, no luck, i used my Google Pixel 2xl no luck... called customer service... no luck. So the pods were replaced.

The new pods didn't connect i thought it was possibly an android issue and borrowed an iphone to test the software and hardware on iphone thinking that maybe the bluetooth or wifi wasn't disconnecting ( i have ring video doorbell and this was a problem for me before my pixel 2 xl handles disconnecting and changing from bluetooth to wifi better with ring video doorbell than moto g6 phone).

I figured it had to be the modem.. NO WAY 6 pods would ALL be screwed up, but its possible this ONE MODEM was the problem. Turned out it wasnt the modem.. pods still wouldnt connect.. back to customer server...

After i exhausted all other avenues and replaced all components and tried every socket in my house.. i was done.

Then it dawned on me... the one thing i didn't swap out was the software... every device used the latest version from the google play store... so i thought i would try downloading and older version from an .apk site.


I don't want anyone to think I am trying to install a virus or be shady so i am not going to give you the link to the file, but i will tell you that this version Shaw BlueCurve Home_v2.8.1.20190409023116 that i downloaded from an apk mirror site worked for me flawlessly. 10+ hours and replacing all the equipment and 5 agents....

It was the v2.9 software that was the problem for me. I installed an older version and viola.. pods connected.

Hope this helps someone else out.

Labels (2)
Tags (2)
1 Reply

Brilliant! You just described my last 24 hours to perfect...


Brilliant! You just described my last 24 hours to perfection. When I read your suggestion, I dug up an old iPhone, downloaded the Shaw app, and had instant success. THANK YOU!!!

0 Kudos