Highlighted
Jump to solution

Geeni Security Cameras

Grasshopper

I purchased 3 Geeni security camera from Canadian Tire to set up a small security camera system for my house. I purchased 2 Vivid 1080p HD smart indoor wifi cameras for inside my house to view out and I also purchased a Sentry 1080p HD smart floodlight security camera to view the back of my house. 

I could not get the cameras connected to my WiFi network. I called the company, they could not help as all the settings were correct. I then called Shaw. I talked with one of the support staff and we tried troubleshooting everything. The last thing to try was to switch out the modem. I was initially using a Hitron CGNM-2250 modem for my home network. The Hitron modem was not connecting the cameras. I switched out my modem for a Cisco DPC3848V. The cameras were able to connect to my home network after I switched to the Cisco modems.
 
I hope this helps others who are trying to hook up these cameras to their home network.
 
Labels (1)
1 Solution

Accepted Solutions
Highlighted
Jump to solution

I bought some Geeni plugs and had trouble hooking up thro...

Grasshopper

I bought some Geeni plugs and had trouble hooking up through my Hitron router as well. Called Geeni support but they are useless. I managed to connect by doing the following:

  1. Log into router.
  2. Temporarily turn off 5G. (Factory settings use the same password for 2.4G & 5G and the device doesn't work on 5G)
  3. On the 2.4G settings, change the Auth mode to "Auto (WPA-PSK/WPA2-PSK)". 
  4. After device connects, turn 5G back on.

View solution in original post

Reply
Loading...
6 Replies
Highlighted
Jump to solution

I bought one of these a couple weeks ago. I had to mess a...

Grasshopper

I bought one of these a couple weeks ago. I had to mess around with the wifi encryption and other settings to get it to connect. I'm going to contact Shaw anyway since my 5Ghz seems to be randomly cutting out anyway. After I got it connected, I moved it to a different location and now have audio artifacts when viewed live. I didn't expect much when I bought It, but I think their firmware leaves a lot to be desired. It seems like the audio playback comes through the earpiece on my Samsung Galaxy S10e and not the speakers. And now after updating to Android 10, the app isn't even in the app store?? I might try other apps, since merkury makes the camera and there are other apps by them. Might come back to update this.

0 Kudos
Reply
Loading...
Highlighted
Jump to solution

Wow no edit button?? Forgot to mention that the box says...

Grasshopper

Wow no edit button?? Forgot to mention that the box says Geeni Vivid, like @pfpmb does, but a Google search doesn't show anything with the same name, even on the Geeni site. Maybe the LOOK model has been replaced by this and it hasn't been updated? 🤔

0 Kudos
Reply
Loading...
Highlighted
Jump to solution

Hi. I just switched to shaw and they gave me the Hitron m...

Grasshopper

Hi. I just switched to shaw and they gave me the Hitron modem but the problem is, some of the devices won't connect and the 5G  wifi won't even appear on some devices so I am using the non 5G. My question is, does the Cisco modem works with any devices you have? Thanks. 

0 Kudos
Reply
Loading...
Highlighted
Jump to solution

> the 5G WiFi won't even appear on some devices ... What...

Grand Master

> the 5G WiFi won't even appear on some devices ...

What devices do you have, because not all devices support both 2.4 & 5 Ghz.

>  does the Cisco modem work with any devices you have?

It does, for me, with my devices (iPad, iPhone, Lenovo tablet, laptop, and more).

 

Reply
Loading...
Highlighted
Jump to solution

I bought some Geeni plugs and had trouble hooking up thro...

Grasshopper

I bought some Geeni plugs and had trouble hooking up through my Hitron router as well. Called Geeni support but they are useless. I managed to connect by doing the following:

  1. Log into router.
  2. Temporarily turn off 5G. (Factory settings use the same password for 2.4G & 5G and the device doesn't work on 5G)
  3. On the 2.4G settings, change the Auth mode to "Auto (WPA-PSK/WPA2-PSK)". 
  4. After device connects, turn 5G back on.

View solution in original post

Reply
Loading...
Highlighted
Jump to solution

Thank you, it took a few tries for me but your fix worked...

Grasshopper

Thank you, it took a few tries for me but your fix worked. This is going to sound obvious but if you are doing this do it from a computer that is connected to the internet with cable, not wifi. 

Thanks for your help!

Reply
Loading...
TALK TO US
Need more help?