Internet 300 getting me 25 mbps

Not applicable

I have internet 300, and it has been good, until recently; the internet became very slow, on average about 25 mbps. We even called a Shaw technician in to help fix it, but he couldn't figure out what was wrong. Also, the Shaw speed test gives about 150 mbps, but the google one gives 15, and other ones in between those 2. Loading anything with servers nearby seems to be good, but even loading google or youtube takes a while.

Please and thanks,

Jeet

Labels (2)
9 Replies

Re: Internet 300 getting me 25 mbps

Moderator
Moderator

Hey jeet,

Thanks for reaching out. It may be a settings related issue, are you noticing the same issue across all of your devices or just one? Do you have any special DNS or VPN settings? Also, are the speed tests over WiFi or a direct connection with a desktop? Let me know so I may help

Cheers,

Tony | Community Mod.

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Not applicable

Hi Tony, my laptop (ethernet) and phone (wifi) are at 25mbps, but another phone in the house(wi-fi), is at 300 mbps. I do not have any DNS or VPN settings. 

Thanks, 

Jeet

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Moderator
Moderator

Thanks! Are you using just the Shaw modem or do you have a separate router as well?

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Not applicable

We are using the new Shaw 2 in 1 modem/router. (Just got replaced because of the issue above, but it hasn't fixed anything unfornunately.

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Moderator
Moderator

jeet It may be a device setting or limitation if one of your other phones is getting 300 Mbps. Is your laptop ethernet port gigabit enabled and running full duplex? If it is, please run the laptop in safe mode with networking and try another speed test.

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Not applicable

I believe it is my device now, as I followed the instructions on this youtube video https://www.youtube.com/watch?v=-IdLQsc2ZE8 (I only used the first 3 tips). Now my phones are getting 200+ mbps, but my laptop is still at 10mbps (On wifi and ethernet). My laptop's ethernet port is only 100mbps, and it is running full duplex. The speed test wielded the same results in safe mode

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Moderator
Moderator

Have you tried resetting your network adapter? That might be worth a try, so if you want to give it a go you can find the steps on https://community.shaw.ca/docs/DOC-1037

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Not applicable

Actually, I am now getting 250 mbps, which is great! Unfortunately, I am getting frequent ping spikes of 250 ms, but it goes all the way to 3500 ms (On Vancouver servers)

0 Kudos
Reply
Loading...

Re: Internet 300 getting me 25 mbps

Moderator
Moderator

 That is certainly odd. Which Vancouver servers are you testing the connection to? Does Google or Youtube display the same ping spikes?

0 Kudos
Reply
Loading...
TALK TO US
Need more help?